Teamspeak Server Ressource
Menu

Die Teamspeak 3 Plugin API: Versionen und Informationen

TS3 Plugin API

Wer Plugins für den Teamspeak 3 Client nutzt, hat sicherlich schon einmal festgestellt, dass die installierten Plugins nach manchen TS3 Client Updates nicht mehr laufen. Dann wird im Pluginmanager die Fehlermeldung Plugin failed to load: Api version is not compatible angezeigt.





Ein Bild vom TS3 Plugin-Manger mit inkompatiblen APIs:

Teamspeak 3 Plugin Manager

Ob Teamspeak 3 Plugins funktionieren oder nicht, hängt von zwei Faktoren ab:

  1. Welche API Version der aktuell installierte TS3 Client hat
  2. Mit welcher API Version das TS3 Plugin kompatibel ist

Anders gesagt: Client und Plugin müssen die gleiche API haben.

API steht übrigens für Application Programming Interface. Das ist sozusagen die Schnittstelle zwischen Client und Plugin. Die Plugin API wird regelmäßig aktualisiert und kommt dann mit der neuesten TS3 Client Version auf den Rechner.

Wenn dann ein Client mit einer neuen API erscheint, funktionieren die installierten Plugins nicht mehr. In diesem Fall müssen alle installierten Plugins ebenfalls aktualisiert werden. An dieser Stelle ist man dann von den Plugin Entwicklern abhängig. Diese müssen ihr Plugin auf die neue API anpassen.



Teamspeak 3 API Versionen

  • API 19 ab Client 3.0.9 - 23.10.2012
  • API 18 ab Client 3.0.8.1 - 30.07.2012
  • API 11 ab Client 3.0.0-rc1 - 10.05.2011
  • API 8 ab Client 3.0.0-beta28 - 09.09.2010
  • API 7 ab Client 3.0.0-beta25 - 06.08.2010
  • API 6 ab Client 3.0.0-beta23 - 02.08.2010
  • API 5 ab Client 3.0.0-beta21 - 31.05.2010
  • API 4 ab Client 3.0.0-beta18 - 30.03.2010
  • API 3 ab Client 3.0.0-beta12 - 20.01.2010
  • API 2 ab Client 3.0.0-beta11 - 18.01.2010
  • API 1 ab Client 3.0.0-beta1 - 19.12.2010

Siehe auch: Teamspeak 3 Plugins | TS3 Server | TS3 Server mieten

 
Impressum Kontakt Linkus